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INTRODUCTION 

Software Applications 30S is an entry-level course for students who want to develop a working 
knowledge of fundamental Software Applications using a Windows platform.  
 
Upon completion of the Software Applications Course 30S, students will have achieved a basic 
understanding of how computer programs work.  
 
Topics covered are:   

� using an operating system (including file management)  
� using the Internet 
� managing e-mail  
� creating documents with a word processor 
� spreadsheet 
� database 
� presentation program 

 
If you have sufficient skills in these areas, you may be able to obtain full or partial credit for this 
course through Prior Learning Assessment and Recognition (PLAR).  
 
The document contains the general course learning outcomes for Software Applications 30S, 
along with a self-assessment checklist of all of the specific learning outcomes covered in the 
course. After completing the checklist you will be able to determine if you have enough prior 
learning to go through the PLAR process for this course. 
 
The PLAR process for Software Applications 30S is outlined in this document. By completing 
the PLAR process in its entirety and achieving the minimum standard, you could receive credit 
for Software Applications 30S without taking the course.  
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Learning Outcomes and Elements of Performance  

After completing the Software Applications 30S course, students will be able to: 
 
1. Explain how a computer functions 

1.1. Identify the physical components of a computer 
1.2. Discuss computer processing and storage 
1.3. Explain an operating system 

1.3.1. Define an operating system 
1.3.2. Explain the need for a operating system 
1.3.3. List several specific operating systems 
1.3.4. Describe ways to load the operating system 

1.4. Differentiate between an operating system and application programs 
1.5. Recognize the benefits of computers for personal and business use 

 
2. Describe the importance of a computer network 

2.1. Explain the topography of a network 
2.2. Label a diagram of a network 
2.3. Login in and out of a network 

 
3. Manipulate a computer operating system 

3.1. Start and shut down a computer 
3.2. Identify parts of the desktop 
3.3. Manage a program window 

3.3.1. Open a program 
3.3.2. Name the parts of a program window 
3.3.3. Move and change the size of a window 
3.3.4. Select program options with menus and dialog boxes 
3.3.5. Close a program 

 
4. Create a file management system   

4.1. Define file management terms  
4.2. Create folders and subfolders 
4.3. Display the contents of a disk 
4.4. Describe various file properties 
4.5. Manage data files:  move, copy, delete 
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LEARNING OUTCOMES AND ELEMENTS OF PERFORMANCE 

5 Manage email software 
5.1 Define terms related to e-mail operations 
5.2 Create and send a new mail message 
5.3 Retrieve and store e-mails 
5.4 Open a mail message 
5.5 Attach a file to a new message  
5.6 Create folders to manage e-mail messages 
5.7 Delete email messages (and empty trash) 
5.8 Create and insert names in an address book 

 
6. Explain Internet history 
 
7. Locate and retrieve information from the Internet 

7.1 Open Internet sites using addresses 
7.2 Manage temporary Internet files and cookies 
7.3 Add and delete sites to favourites/bookmarks 
7.4 Set a home page 

 
8. Search the Internet for information 

8.1 Copy and save pictures 
8.2 Insert text and pictures from the Internet into Word and Excel 
8.3 Transfer files from the Internet to the hard drive  
 

9. Create and modify documents created using application software  
9.1 Explain the purposes of a: 

9.1.1 word processor 
9.1.2 spreadsheet 
9.1.3 database 
9.1.4 presentation program 

9.2 Define concepts/terms unique to different software applications 
9.3 Control the setup and views of each program window 

9.3.1 Add/remove toolbars 
9.3.2 Change views/zoom 

9.4 Edit text 
9.4.1 Add and delete text 
9.4.2 Move and copy text 
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LEARNING OUTCOMES AND ELEMENTS OF PERFORMANCE 

 
9.5 Create new files using application templates 
9.6 Save, open, and close application files 

9.6.1 Manage read-only files 
9.7 Format documents 

9.7.1 Apply standard font attributes 
9.7.2 Change paragraph properties 

9.8 Modify page setup 
9.8.1 Change paper size and orientation 
9.8.2 Adjust document margins 
9.8.3 Create headers and footers 

9.9 Print documents using different program options  
 
10. Explain software integration 

10.1 State advantages and needs of integration 
10.2 Integrate a spreadsheet selection with a word-processing document using copy 

and paste 
10.3 Link a spreadsheet with a word processing document as an object 
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Course Resources  

The following is a list of possible resources used in this course.  
 
References 
 

DDC series:  “Learning . . . . . Assorted Titles. Prentice Hall Publishers. 
www.ddcpub.com 
 
Shelly Cashman series . . . Assorted Titles.  Thomson Course Technology. 
www.scsite.com 
 
New Perspectives on . . . Assorted Titles. Course Technology, Thomson Learning, 
2002. www.course.com 
 
A Guide to . . . Assorted Titles. Lawrenceville Press, Pennington, NJ, 2000. 
www.lawrencevillepress.com 
 
Assorted titles including the IDG series, and “Dummies” books.  Wiley Publishers. 
www.wiley.ca 
 
Teach Yourself Visually . . . Series, Assorted Titles.  J.W. Wiley Publishers. 
www.wiley.ca 
  

 

Reference Web sites: 

Microsoft 
www.microsoft.com 
 
Government of Canada  - Internet Guide 
http://www.cio-dpi.gc.ca/ig-gi/links/links-liens_e.asp?format=print 
 
General computer knowledge 
www.about.com 
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PLAR Challenge Process Assessment  

 
Course:  Software Applications  
Course Number:  30S 

 
Self - Assessment Checklist 
 
The checklist indicates all of the learning outcomes covered in the Software Applications  
30S course. Use it to measure your abilities in the different areas and uncover weak areas.  
If you have: 
 

125 or more  

9 

93-124 

9 

Less than 93 

9 

You have a good chance 
of succeeding in the PLAR 
process 

You could proceed with 
the challenge process 
after self study to improve 
in weak areas 

Take the Computer 
Application 30S course. It 
is unlikely that you would 
be successful in the PLAR 
process. 

 
 
Your adult learning center may give you PLA recognition for individual sections of the Software 
Applications course. Ask the PLAR advisor if this is an option. 
 
PLAR Challenge Assessment Process  
 
Once you have completed the self-assessment and decide that you are ready to challenge 
Software Applications 30S course or individual units, go on to the Assessment section. The 
Assessment section outlines different assessment procedures that you might go through in 
order to receive recognition for this course (or a unit) through the PLAR process.  
 
NOTE:  Individual adult learning centers may have additional requirements. Speak to the PLAR 
advisor for more information. 
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Self- Assessment Checklist  

Check the box to show whether you can perform the function. 
 
Computer Services  Total possible number of 

checkmarks is 38
 Function Yes 

9 
No 
9 

Comments 

1 Define and give examples of input and output    

2 Describe the function of the CPU or microprocessor    

3 Identify and explain internal and external storage 
media 

   

4 Compare RAM and ROM    

5 Explain the set-up of a network     

6 Explain the process of signing on and off a network    

7 Discuss the impact of computers on everyday life    

8 Differentiate between operating system software and 
application software 

   

9 Compare and contrast My Computer and Windows 
Explorer  

   

10 Change the view and arrangement of file icons    

11 Create folders and subfolders     

12 Move, copy and delete files using mouse and menu 
options 

   

13 Select multiple files and groups of files    

14 Rename files and folders    

15 Change the properties of a read-only file    

16 Format a diskette    

17 Explain file name standards (Windows or Mac)     

18 Identify typical file extensions and icons    

19 Explain how to use the Recycle Bin    

20 Demonstrate how to use the mouse (left and right 
buttons, scroll button; single click, double click) 

   

21 Customize the desktop (arrange icons, create 
shortcuts) 
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SELF - ASSESSMENT CHECKLIST 

Computer Services continued 
 
 Function Yes 

9 
No 
9 

Comments 

22 Discuss current issues in computer ethics    

23 Identify the parts of a program window    

24 Activate program menus or shortcut keys    

25 Explain different menu conventions (check mark, 
ellipsis, triangular arrow, greyed-out options, 
keyboard shortcut, double arrow) 

   

26 Move a window    

27 Size a window    

28 Explain the purpose of the minimize and 
maximize/restore buttons 

   

29 Close a window    

30 Identify and explain parts of the desktop (icons, task 
bar, start button) 

   

31 Manipulate dialog box features:  option button, text 
box, check box, drop-down list, what's this button, 
Cancel (close) button 

   

32 Access the Help menu and online help    

33 Run system tools:  scan disk, defrag    

34 Search for folders or files    

35 Troubleshoot simple hardware problems    

36 Choose an appropriate system    

37 Define computer viruses and the problems they can 
cause 

   

38 Explain how to prevent or remove viruses    

 
Total possible number of checkmarks is 38. 
Total number of Yes checkmarks from your self-assessment =   . 
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SELF - ASSESSMENT CHECKLIST 

Word Processing Software Total possible number of 
checkmarks is 21

 Function Yes 
9 

No 
9 

Comments 

1 Manage the word processing window    

2 Identify parts of the word processing screen    

3 Create and save a new file    

4 Open an existing document     
5 Select text in a document    

6 Rename a document    

7 Change screen views and zoom options    

8 Insert and delete text     

9 Move or copy text within a document and to other 
documents using menus, shortcut keys or mouse 

   

10 Demonstrate font formatting (size, style, bold, italics, 
underline, colour) 

   

11 Apply paragraph formatting (alignment, indents, line 
spacing, bullets/numbering,) 

   

12 Insert symbols    

13 Change page set up options (margins, header/footer, 
orientation) 

   

14 Insert pictures from ClipArt Gallery or other sources    

15 Manipulate pictures (move, change size, wrap 
borders, contrast, brightness) 

   

16 Create and edit columnar lists using tabs or tables    

17 Repeat font or paragraph features using the Format 
Painter button 

   

18 Insert page breaks    

19 Demonstrate editing using a variety of tools (spelling 
and grammar check, find, replace) 

   

20 Print documents    

21 Create a variety of mailable documents     
 
Total possible number of checkmarks is 21. 
Total number of Yes checkmarks from your self-assessment =   .
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SELF - ASSESSMENT CHECKLIST 

Presentation Software Total possible number of 
checkmarks is 25

 Function Yes 
9 

No 
9 

Comments 

1 Manage the presentation window    

2 Plan and create a presentation using a blank layout    

3 Open and save a presentation file     

4 Insert new slides    

5 Apply different slide layouts    

6 Promote and demote text     

7 Explain the differences between outline, notes, slide 
show and normal view 

   

8 Insert or edit text in Outline and Slide views    

9 Move text on a slide (in outline or slide view)    

10 Change the order of, or delete slides    

11 Insert pictures on slides (ClipArt and From File)    

12 Create and format a text box    

13 Create and change the appearance of drawing 
objects  (move, copy, size, rotate, add text) 

   

14 Insert and format WordArt    

15 Change slide background features    

16 Apply a design template    

17 Change font styles    

18 Apply animation features to text or objects    

19 Access and edit the slide master    

20 Apply slide timings    

21 Apply slide transitions    

22 Orally present a slide show to a group    

23 Print slides in a variety of formats    
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SELF - ASSESSMENT CHECKLIST 

Presentation Software continued 
 
 Function Yes 

9 
No 
9 

Comments 

24 Print audience handouts and speaker notes    

25 Start a slide show on any slide    

 
Total possible number of checkmarks is 25. 
Total number of Yes checkmarks from your self-assessment = ___________. 
 
 
Spreadsheets 
 

Spreadsheets Total possible number of 
checkmarks is 26

 Function Yes 
9 

No 
9 

Comments 

1 Manage the spreadsheet window    

2 Create and save a new spreadsheet    

3 Open an existing document     

4 Input and edit data    

5 Select range(s) using the mouse or keyboard    

6 Create and name a range    

7 Insert a range name in a formula    

8 Work with series (AutoFill)    

9 Modify row and column size    

10 Insert and delete columns and rows    

11 Hide and unhide columns and rows    

12 Move or copy data using menus, shortcut keys or 
mouse 

   

13 Change font attributes    

14 Apply number styles (comma, currency, percent)    
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SELF - ASSESSMENT CHECKLIST 

Spreadsheets continued 
 
 Function Yes 

9 
No 
9 

Comments 

15 Apply cell borders and shading    

16 Modify alignment of cell content    

17 Merge cells    

18 Rotate text and change indents    

19 Enter formulas to perform basic calculations    

20 Create formulas using simple functions:  SUM, 
AVERAGE, COUNT, MIN, MAX 

   

21 Differentiate between absolute, relative and mixed 
cell references 

   

22 Create charts using the Chart Wizard    

23 Modify charts    

24 Preview and print charts    

25 Change page set-up (margins, headers/footers, 
alignment) 

   

26 Print entire pages or selected ranges    

 
Total possible number of checkmarks is 26. 
Total number of Yes checkmarks from your self-assessment = ___________. 
 
Database  
 
Database Total possible number of 

checkmarks is 23
 Function Yes 

9 
No 
9 

Comments 

1 Explain purposes of databases    

2 Create a new database    

3 Open an existing database    

4 Define database terms    
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SELF - ASSESSMENT CHECKLIST 

Database continued 
 
 Function Yes 

9 
No 
9 

Comments 

5 Create a table in design view    

6 Add/delete records    

7 Sort records    

8 Find a record    

9 Apply and remove filters (filter by form and filter by 
selection) 

   

10 Print a table in datasheet view    

11 Customize field properties    

12 Establish and print relationships    

13 Create a query using the wizard    

14 Create and edit queries in design view    

15 Specify criteria in a query    

16 Create a delete query    

17 Prepare reports using the wizard    

18 Create a form using the wizard    

19 Insert a calculated field in a report    

20 Add objects to a report or form using the Control 
Toolbox 

   

21 Move and resize a control    

22 Preview and print a report    

23 Apply an autoformat to a form or report    

 
 
Total possible number of checkmarks is 23. 
Total number of Yes checkmarks from your self-assessment = ___________. 
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SELF - ASSESSMENT CHECKLIST 

Internet/E-mail  
 
Internet/E-mail Total possible number of 

checkmarks is 20
 Function Yes 

9 
No 
9 

Comments 

1 Create and send e-mail    

2 Retrieve and store e-mails    

3 Attach a file to a mail message    

4 Create folders to manage e-mail messages    

5 Delete email messages (and empty trash)    

6 Create and insert names in an address book    

7 Define Internet terms    

8 Manage the parts of a browser window    

9 Identify the parts of a URL    

10 Use the address bar    

11 Look for information on the Internet using search 
engines and directories 

   

12 Copy information from the Internet into a Word or 
Excel document 

   

13 Save and insert a picture from the Internet into a 
document 

   

14 Create, use and manage bookmarks/favourites    

15 Explain the history of internet    

16 Define internet terms    

17 Determine reliability of web resources    

18 Explain the process of downloading programs    

19 Practice netiquette    

20 Select an ISP    

 
Total possible number of checkmarks is 20. 
Total number of Yes checkmarks from your self-assessment = ___________. 
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SELF ASSESSMENT CHECKLIST 

Integration  
 

Integration Total possible number of 
checkmarks is 3

 Function Yes 
9 

No 
9 

Comments 

1 State the advantages of integration    

2 Integrate a spreadsheet range into a word 
processing document 

   

3 Link a spreadsheet with a word processing document    

 
Total possible number of checkmarks is 3. 
Total number of Yes checkmarks from your self-assessment = ___________. 
 
 
Suggested Course of Action 
 
Enter your total checkmarks from each assessment below. 
 

 
Total possible number of 

checkmarks is 156. 
 
Discuss your results with an 

Adult Learning Centre 
PLAR Advisor. 

Computer Systems     
Word Processing Software    
Presentation Software    
Spreadsheets      
Database      
Internet/E-mail      
Integration      

Total    

125 or more  

9 

93-124 

9 

Less than 93 

9 

You have a good chance 
of succeeding in the PLAR 
process 

You could proceed with 
the challenge process 
after self study to improve 
in weak areas 

Take the Computer 
Application 30S course. It 
is unlikely that you would 
be successful in the PLAR 
process. 
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PLAR Challenge Process 

If you feel that your current skills and knowledge match or exceed what is being taught in the 
Software Applications 30S course, you can move ahead with the PLAR process. The PLAR 
process can consist of any of the following methods of evaluating your knowledge of all or 
specific units of the course. These are examples of some of the assessment tools that can be 
used by PLAR assessors; individual learning centers may use other evaluation methods. 
 
Case Studies (examples) 

� organize a file management system  
� create a document given general guidelines 
� prepare and deliver a topic using a presentation package 
� design a database 

 
Task Specific Assignments 

� open various software files and make changes 
� edit or format a document given specific instructions 
� create a database file including tables, queries and reports 
� send an e-mail message, including options 

 
Interview/Demonstration 

� bring samples of work (E.G. letters, tables, reports, spreadsheets) and discuss 
setup, formatting, etc. 

� explain how to manipulate program screen 
 
Reflections on Samples 

� reflections include thoughts and feelings about your computer skills and 
accomplishments.  

� sample reflection questions can include: 
→ What have you produced?   
→ What new skills did you learn in producing your work?   
→ What new knowledge have you gained?   
→ What was the most difficult part of completing the work?   
→ Why do you think it was difficult or easy for you? 
→ What was the most satisfying thing that happened?   

 
Tests 

� Multiple choice or short answer (See next page; correct answers are bolded) 
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PLAR CHALLENGE PROCESS 

These are examples of possible test questions. The bold text indicates a correct answer. 
 

Sample Test  
 
A fast way to add up a column of numbers is to click in the cell below the numbers and then:  
 

a. Click Subtotals on the Data menu.  
b. View the sum in the formula bar.  
c. Click the AutoSum button on the Standard toolbar, then press ENTER. 

 
How should you print a selected area of a worksheet, if you'll want to print a different area next 
time?  

a. On the File menu, point to Print Area, and then click Set Print Area. 
b. On the File menu, click Print, and then click Selection under Print what. 
c. On the View menu, click Custom Views, then click Add. 

 
What's a quick way to extend two numbers to a longer sequence, for instance 1 through 20?  
 

a. Select both cells, and then drag the fill handle over the range you want, for 
instance 18 more rows. 

b. Select the range you want, including both cells, point to Fill on the Edit menu, and then 
click Down. 

c. Copy the second cell, click in the cell below it, on the Standard toolbar click the down 
arrow on the Paste button, and then click Paste Special. 

 
How do you change column width to fit the contents?  
 

a. Single-click the boundary to the left of the column heading. 
b. Double-click the boundary to the right of the column heading. 
c. Press ALT and single-click anywhere in the column. 

 
Suppose you have columns of data that span more than one printed page. How can you 
automatically print the column headings on each page?  
 

a. Click Page Setup on the File menu, click the Sheet tab, and enter the row that 
contains these column headings under Print titles. 

b. Click Page Setup on the File menu, click the Page tab, click the Options button, then 
enter your choices. 

c. Click Page Setup on the File menu, click the Sheet tab, and make a selection under the 
Print heading. 
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PLAR CHALLENGE PROCESS 

Sample Test continued 
 
Your document is five pages long. How can you number the upper-right corner of each page so 
that it says "Page 1 of 5," "Page 2 of 5," and so on, whenever it's printed? 
 

a. On the View menu, click Header and Footer, and then click the Align Right button 
on the Formatting toolbar. On the Header and Footer toolbar, click the Insert 
AutoText button, and then click Page X of Y. 

b. On the File menu, click Page Setup, click the Layout tab, and then under Headers and 
footers, click Different odd and even. 

c. On the Format menu, click Bullets and Numbering, then click the Numbered tab and 
assign numbers to the preferred location on your pages. 

 
If you've just formatted some text so that it stands out, how can you quickly copy that formatting 
to use on other text? 
 

a. Click anywhere in the formatted text, double-click the Formatting toolbar boxes showing 
the font name and size, then click where you want the same format, and start to type. 

b. Select the formatted text. On the Format menu, click Reveal Formatting. Do the same in 
the other text to learn what you need to change. 

c. Select the formatted text. On the Standard toolbar, click the Format Painter button, 
select the other text, then release the mouse button. 
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THE NEXT STEP  

Now that you are confident in proceeding with the challenge process for Software Applications 
30S, it is time to apply for and complete the challenge assessment. 
 
 

11 Complete an application at your adult learning center. 
 
 

12 After your application has been processed, you will be contacted with the date and time 
available for you to complete your PLAR assessment. 

 
 

13 Once you have committed to that date, you are responsible for completing your 
evaluation/testing.  

 
 

14 You will receive written notification of your PLAR results. 
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